Server never finished after purchase

This thread is marked as resolved, please create a new thread.
  • I purchased and was charged for a Conan Exiles server (10-person, 90-day), but the server never finished setting up.


    I cannot find the server and now it wants me to buy a server again.


    How do I get it to finish setting up the server that I already purchased this morning, without being double-charged?

  • This is really frustrating. I was told by Support to CLAIM SERVER and report back to them. I tried to CLAIM SERVER through the XBOX and through G-Portal website multiple times and both end in error message, SERVER CANNOT BE FOUND.


    Advertising is a server in 3 minutes. I am going into hour 3 and nothing, but my credit card was charged in 3 minutes or less. ;-(

  • That's ok. Mine set up but doesn't show. In game, I will take a refund what a headache, 2 hours after launch and I'm still not playing.

    Has Support even been in contact with you? I understand that it is the first day of the Conan Exiles launch, but I would have thought G-Portal would be better prepared than what I have seen so far. I purposefully waited to rent the server so I would not have to do a wipe on the launch date.

  • Hello Sir,


    please open a ticket with our support team so we can check on that, its impossible for us to deal with that issue here on the forum since there are plently of infos missing. And yes we have issues currently and trying to solve them, sorry for that.