Zero clue on how to submit a ticket.

  • I have scoured these forums and have seen people get responded to how to submit their own tickets to customer support but I have no option to submit my own ticket. I am having constant problems with the simplest things here like the website not saying I own a server when the banked charged me for it and I can connect to it through FTP and many more problems! I need a response asap before I lose my patience and demand a refund and never use your service again.

  • I do not have that option on my screen whatsoever. I saw you posted the same picture on a previous thread I read. Again, I don't have that option at all.

  • I used the link you posted and it sent me to renting a server. I already rented one and have connected to it through FTP and have bank statements saying you guys charged me but on this website it is saying I don't have one. Not sure why this is happening.

  • Hai NattiTheBaddi,

    If you click on the link as Fairy Mod Mother has posted are you still logged in?

    When i clicked on the link it opened a new tab for me but i wasn't signed in.

    If you see the Rent a server again, sign in, perhaps you can find it then. Still no option? Try to click on the link again after you closed that tab. Worked for me :)

    Hope this helps

    Kind regards,

    🐾 𝓚𝓪𝓽𝓷𝓲𝓼𝓼 🐾

  • I have tried all of those options. I am logged in, how would I be able to post on this forum. I have logged out and back in over 10 times now and used that link and it keep redirecting me to the rend a server. The control panel just wont pop up and I think it is because the websites doesn't think I own a server with them. I do not know why but I can provide all the info I have been given to prove I did in fact rent a server from you guys.

  • That is strange as it is working for me.

    Before i had to re-log as there is a timer i believe that it signs you out if you haven't been on it for a while.

    What kind of internet browser are you using?

    🐾 𝓚𝓪𝓽𝓷𝓲𝓼𝓼 🐾

  • I am using Microsoft edge. I relogged once more and it still is not showing my server through the link the other admin gave me to put in a ticket. I am currently connected to the server through FTP and can alter files in there just fine.