Poor RAM for Server

  • New to forums, but I've been using G-Portal for about a week now for our Conan Exiles server. Lately, I have noticed tremendous lag in enemy movement and action. I went to our Conan Exiles server page here on G-Portal and saw that our server usage was topping out for the RAM. I've done a couple of restarts which helps for a while, but then we run into the same issue again.


    I've looked throughout these forums, and have noticed that a few others are running into the same issue with high RAM usage and it capping out - moderators are saying to ignore it, even though the issue persists. Is there a way to upgrade allocated RAM for our server? Or will we have to migrate to a new service provider?


    Thanks.

  • I've absolutely no mods on our server with no changes to configuration settings, besides the name of the server and a password.


    I was unable to find where to submit a ticket at the time, but I'm going to be submitting one in the next few minutes of this post.

  • Hello,

    We do not cap ram, what you see under the status page is simply a display and will go over as needed.

    Good to know, is there an option to increase the available ram to improve smoothness? I'm running a heavily modded server and running into the floating over certain foundations bug several times. Resets seem to help, but I would add more power to the server to avoid the bug in the first place if I could. I saw elsewhere that adding slots to the minecraft servers increased available ram. I bumped it from 10 to 16 but not seeing any changes in the server status.


    EDIT: Description of bug and suspected cause: https://steamcommunity.com/app…ns/0/2561864094344755745/

    The post was edited 1 time, last by Blreitze: Adding links for reference ().

  • Ram is not capped, its dynamic, adding slots etc doesnt change the amount that is available :-) From reading your link, that is not ram related, but a game issue itself.


    I run a heavily modded conan, and dont having any issues :-)

    FMM

    (my views are my own)

  • Ram is not capped, its dynamic, adding slots etc doesnt change the amount that is available :-) From reading your link, that is not ram related, but a game issue itself.


    I run a heavily modded conan, and dont having any issues :-)

    It's a game related issue from having insufficient resources to process a poorly optimized database system. Luckily it seems to resolve itself with a server reset (running the database again without the dynamics of having just placed new items.) But I worry about boosting RAM since I don't have the issue on my solo server on my personal machine (no glitches or slowdowns at all yet) but that's running 32GBs of ram. Server seems to hovering around 7GB, and still hasn't added the extra 6 player slots despite me boosting it in gamecloud 2 days ago (though you mentioned that doesn't affect it). I only have one megabase and a few players right now but am experiencing that glitch and slow downs in pulling up inventory screens (full of building items). I'm worried adding more players will overtax it.


    So I guess the next real question is when does the g-portal system determine I need more ram and when does it add it? All the time minute by minute? Only after a reset? Maybe a day later after seeing use expanded?

  • its as needed.. and you have added slots to the cloud, but have you added the slots then to the server?


    any game, be it ark, atlas, conan, will get laggy with mega bases on it, its a sync type issue.. you go to a base that has over 5000 items for example, and it will slowly load tht base in. the bigger it is the worse it is. this wont occur on a sp game, because you dont need to sync with another server, over poorly maintained cable/fiber optics that run for 1000's km. (or swim with the fishes ;-))

    FMM

    (my views are my own)

  • its as needed.. and you have added slots to the cloud, but have you added the slots then to the server?


    any game, be it ark, atlas, conan, will get laggy with mega bases on it, its a sync type issue.. you go to a base that has over 5000 items for example, and it will slowly load tht base in. the bigger it is the worse it is. this wont occur on a sp game, because you dont need to sync with another server, over poorly maintained cable/fiber optics that run for 1000's km. (or swim with the fishes ;-))


    Slots have been added to the server and it says 16 on the gamecloud status page, but not on the individual server page nor the steam listing (says 0/10 players)


    I'm okay with it being laggy loading in (currently sitting at over 12,000 pieces) , I just want to make sure its ensure its playable once loaded, otherwise no point in paying someone else to host the server. So far so good, but we'll see.

  • That is a lot of structures. I built a castle with 9500 structure items, it caused lag when people came to my base. This is with any host. It has to render in, which takestime


    You actually need to add the slots to the server as well. You can buy eg 20 slots and apply those to 2 servers.


    There is a pencil icon that you click on, and add the extra slots there

  • That is a lot of structures. I built a castle with 9500 structure items, it caused lag when people came to my base. This is with any host. It has to render in, which takestime


    You actually need to add the slots to the server as well. You can buy eg 20 slots and apply those to 2 servers.


    There is a pencil icon that you click on, and add the extra slots there

    Yep got that set and it says so in the gamecloud dashboard, just not showing up in the status or Steam connect.