Map Issues - Workaround

  • Hi All,


    Players on the server 2x2 server running the 2x2 map are unable to see the map in game. This means they are unable to choose beds to spawn, treasure maps don't work, and its just a pain in general.

    I believe the issue lies in one of the following areas:

    1. The ServerGrid.json is wrong, and doesn't have the correct names for the maps coded in it. As I can't see this there is no way to know if it's correct.

    2. Permissions, the files are located on the ftp server and its possible that users are unable to download it through the game.


    Part A. FTP Side

    The following steps require FTP access, and worked for myself and 3 other players in my server.

    1. Connect to the FTP, download all the files located here, the quantity will depend on the amount of tiles on your servers map.


    2. Rename the files to the following:

    3. Zip these files up, and send them to the players, I used email but if its zipped it doesn't matter how you do it. Sending over discord as images broke ours and it took me a long time to determine why it worked for me and nobody else.

    Part B. Adding them to the folder and clearing cache.

    On each clients machine, there is a cache of maps already download, and the information on the areas of the map that are explored.

    1. Clear the cache

    C:\Program Files (x86)\Steam\steamapps\common\ATLAS\ShooterGame\Saved\LocalProfiles

    You will notice there is multiple files in here, these are created for each server, which has a unique ID that is generated when you make the map. To determine which one is the correct server, you can simply enter the server, and then check which one is the latest modified. I'm not sure if this is deliberate but my g-portal server is 4062234234.0, and none of the others have a .0 on the end, as you can see here:

    Make note of the ID of your server, as you need it in step 2.

    This folder contains the map explored details for your characters, it needs to be deleted if the map files don't exist otherwise it doesn't work. Its fine if you just delete the folder (eg. 4062234234.0).

    2. Add map files

    C:\Program Files (x86)\Steam\steamapps\common\ATLAS\ShooterGame\Saved\MapImagesCache

    In this folder, you should be able to see your server ID, open the folder, it will have any maps that you were able to download. If it doesnt exist, create it. Delete everything and put the new files from Part A in here, like so:

    Start the game, check the map and everything should be working.

    BradF   daenrys7 Is it possible to get my ServerGrid.json to see if I can determine if there is any issues? I have tested this extensively on a server on my own PC.



  • i followed that on my 1x1 server and it didnt change anything. i still have maps with nothing. im reinstalling the server to try again now

  • @gportal_122952 Without any modifications? And its working for more than one player?

    Yes we see our map exactly like how it was presented to me when I picked it. I took the link from that specific map and I put it in the server control panel under Basic Settings as the link to the map. Although now that I'm looking again, I don't see that option anywhere on the control panel anymore.

  • gportal_122952

    Does it work for people who connect for the first time?

    My PC managed to download the map initially but nobody elses did. Now if I delete the files it doesn't download them again and I get a grey map.

    Punchy Hmm, its hard to diagnose. Double check the name of the map files you downloaded are correct, re-delete the fow2visibilty file in the C:\Program Files (x86)\Steam\steamapps\common\ATLAS\ShooterGame\Saved\LocalProfiles\<your server ID> folder.

    Your map file should be easy, just named: GridCellMapImage_0-0.jpg

    Note there is a difference between Matt Grey/Black (blank) maps and the foggy maps. Foggy generally seems to be the fow2visibility file being corrupt, but the pure blank one indicates no map exists at all. Post a screenshot of the map in game to see if that works.

    Silvanar I have replied in the other thread, it might be worth starting your own (tag me) and we can diagnose from there. I tested mine and I can transition between servers fine.

  • I cannot for the life of me get my maps to work. I saved a picture of the 2x2 map and named it WorldMapImage and then cropped each section naming those GridCellMapImage_0-0, GridCellMapImage_0-1, GridCellMapImage_1-0 and GridCallMapImage_1-1. I added all of those to my MapImagesCache folder. I went into my FTP, but there wasn't a ServerGrid folder under ShooterGame so I added it manually and then uploaded the map files to it. I deleted my local cache several times and restarted the server and I am still stuck with the "fog of war" issue.

  • My server is also experiencing this fog of war/blank map issue when running the gportal "2X2 FUN ALLBIOMS V4" map. Unfortunately, when accessing the cluster's FTP link there is no " /ShooterGame/ServerGrid/" folder... How can this be?

    Evidently the servers core map layout isn't stored here or we wouldn't have a map to load into but i'm not really sure where to go to get the files that we're surely missing for the minimaps.

    any ideas?

  • ^ I had the same problem support ticket didn't help an either did the workaround, They did seem to upload a new map to choose from for 2x2 which im using now an have no map issues there is even power stones on this map! mind you when i admin cheat fly to them there isnt anything

  • Well hopefully in the next day or two it will be resolved without a wipe for you, fingers crossed man. I haven't even played on my server for more then 4 hours an I've had it for about 9 days now so you are lucky in that regard!