Unable to join my server

This thread is marked as resolved, please create a new thread.
  • Hello all I’m posting this to see if anyone else is having the same issue I goto join my server thru steam using the query port all works to this point as the game is joining my server shuts off any suggestions to fix this would be great

  • Does your server show up in the browser? When i refresh the browser mine shows up for a second then disappears. Also mine looks to be version 6.2.. What about yours?

  • I did the same added then restarted steam, it says joining server then the server goes offline as soon as I try to join

    I was having a similar issue.

    1.I reinstalled my server and that fixed it.

    2. Once that stop working, I deleted my server and remade it then it worked. That's the only work around that I have been able to figure out so far.

    Hope it helps.

  • The maintenance page generally means they are working on the hardware. Give it some more time. I am seeing the same issue, with patience it will be resolved. Thank you and take care.

  • Our server has been stuck on "Stopping" since 11 pm last night. We are understanding, but running out of patience because the maintenance page shows up if we try to delete and reinstall the server, again, since 11 pm last night. We are looking at the Discord server for Atlas and it seems this latest update has Ghost ships spawning like crazy and other new issues to go with it. I know that the GPortal team is working hard to make this game playable for us, i just kinda want to wipe the server instead of pushing an update, seems like when we do that, the game runs much smoother than just updating. any news would be nice.

  • Hello, thank you for your report. Please keep in the forefront that this is an early access game. Weirdness will occur. Devs/programmers/techies will try to squash it and we can get back to playing. Take care